summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorGravatar Benjamin Barenblat <bbaren@mit.edu>2015-07-28 10:38:10 -0400
committerGravatar Benjamin Barenblat <bbaren@mit.edu>2015-07-28 10:38:10 -0400
commit2f6799a42360a995b665244b922ebd3b2275c839 (patch)
tree23102228a85e96561f1ce20c5321d31b573b94d7 /Makefile.am
parenta8b108619083c2088269ea8071c7958f277ed41f (diff)
Replace my bounds-checked numeric conversion with Boost’s
Boost provides numeric_cast, which is much better than what I was using for safe numeric type conversion. This does introduce a Boost dependency, but that tends to be true of most nontrivial C++ programs, so it’s pretty reasonable.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 3cc46e9..cba5a94 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -16,7 +16,8 @@ ACLOCAL_AMFLAGS = -I m4
CPPFLAGS = \
-Wall \
- -D_FORTIFY_SOURCE=2
+ -D_FORTIFY_SOURCE=2 \
+ $(BOOST_CPPFLAGS)
CXXFLAGS = \
-std=c++11 \
@@ -53,7 +54,8 @@ liburweb_regex_la_DATA = \
liburweb_regex_la_LIBADD = -lurweb
liburweb_regex_la_LDFLAGS = \
- -export-symbols-regex '^uw_Regex_'
+ -export-symbols-regex '^uw_Regex_' \
+ $(BOOST_LDFLAGS)
liburweb_regex_ladir = $(datadir)/urweb/ur/regex