summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorGravatar Benjamin Barenblat <bbaren@mit.edu>2015-07-27 17:03:43 -0400
committerGravatar Benjamin Barenblat <bbaren@mit.edu>2015-07-27 17:03:43 -0400
commita8b108619083c2088269ea8071c7958f277ed41f (patch)
tree2bd68e215161d64e34cce66863ab8c0ebd1d44d2 /Makefile.am
parenta6c2ac566bd749c14a29f7d8d9d2d4898b1d49de (diff)
Rework to use the C++11 regex library
Switch to using the C++11 regex library for better portability and ease of use. As an added bonus, this should make it easier to implement regex substitution.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index b3926a2..3cc46e9 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -29,7 +29,8 @@ CXXFLAGS = \
CXXFLAGS += \
-Weverything \
-Wno-c++98-compat \
- -Wno-padded
+ -Wno-padded \
+ -Wno-switch-enum
LDFLAGS = \
-Wl,-Bsymbolic-functions \