aboutsummaryrefslogtreecommitdiff
path: root/util/Makefile.am
diff options
context:
space:
mode:
authorGravatar Miklos Szeredi <miklos@szeredi.hu>2005-06-28 12:22:57 +0000
committerGravatar Miklos Szeredi <miklos@szeredi.hu>2005-06-28 12:22:57 +0000
commit866826d2f211298ad7a969d78d849234595d2a2e (patch)
treef73cd7bd2d5f09fd5039a0fd6a5a3171f173ac06 /util/Makefile.am
parente1bcecec1b042d3ca91391af3840c06e4c8f72ac (diff)
fix
Diffstat (limited to 'util/Makefile.am')
-rw-r--r--util/Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/util/Makefile.am b/util/Makefile.am
index 4b6f7d1..2ac6805 100644
--- a/util/Makefile.am
+++ b/util/Makefile.am
@@ -7,8 +7,13 @@ fusermount_SOURCES = fusermount.c
install-exec-hook:
-chown root $(DESTDIR)$(bindir)/fusermount
-chmod u+s $(DESTDIR)$(bindir)/fusermount
+ @if test ! -e $(DESTDIR)/dev/fuse; then \
+ $(mkdir_p) $(DESTDIR)/dev; \
+ echo "mknod $(DESTDIR)/dev/fuse -m 0666 c 10 229"; \
+ mknod $(DESTDIR)/dev/fuse -m 0666 c 10 229; \
+ fi
-EXTRA_DIST: mount.fuse
+EXTRA_DIST = mount.fuse
install-exec-local:
$(INSTALL_PROGRAM) $(srcdir)/mount.fuse $(DESTDIR)/sbin/mount.fuse