aboutsummaryrefslogtreecommitdiffhomepage
path: root/debian/rules
diff options
context:
space:
mode:
authorGravatar David Adam <zanchey@ucc.gu.uwa.edu.au>2015-07-02 15:06:05 +0800
committerGravatar David Adam <zanchey@ucc.gu.uwa.edu.au>2015-07-09 12:07:44 +0800
commit0effcf6df1b3ba2e186b19c8372d942516be14a4 (patch)
tree431478a08c467d99b553e85238230e792216c730 /debian/rules
parenta5fabc6875747ca35a14f3d6f15f2ce6e608ba39 (diff)
debian packaging: maintain in fish-shell tree
Imported from https://github.com/zanchey/fish-build/ Work on #2020. Note that this is explicitly removed from `git archive` tarballs due to https://wiki.debian.org/UpstreamGuide#Pristine_Upstream_Source
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules25
1 files changed, 25 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 00000000..3936490c
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,25 @@
+#!/usr/bin/make -f
+# -*- makefile -*-
+
+# Uncomment this to turn on verbose mode.
+export DH_VERBOSE=1
+
+# dpkg-dev 1.16.1 doesn't export buildflags
+# can be removed once on dh compat level 9
+DPKG_EXPORT_BUILDFLAGS = 1
+-include /usr/share/dpkg/buildflags.mk
+
+%:
+ dh $@ --with autotools-dev,autoreconf
+
+override_dh_auto_install:
+ dh_auto_install --destdir=debian/fish
+
+override_dh_installdocs:
+ dh_installdocs --link-doc=fish
+
+override_dh_strip:
+ dh_strip --dbg-package=fish-dbg
+
+# Don't run tests; they don't work until fish is installed
+override_dh_auto_test: