summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorGravatar Anders Kaseorg <andersk@mit.edu>2013-11-22 09:36:14 -0500
committerGravatar Anders Kaseorg <andersk@mit.edu>2013-11-22 09:36:14 -0500
commit5ec1f0ef84abc702fa33b36950eefb9895ab1679 (patch)
tree857811d8786740be04a6d3fa73fdad22d51037f9 /Makefile.am
parent16f41881a528ad9e4479cb90989a5d3110fe985f (diff)
xml/parse: Accept entity files on the command line
Signed-off-by: Anders Kaseorg <andersk@mit.edu> --- Makefile.am | 2 +- xml/parse.sml | 4 +--- 2 files changed, 2 insertions(+), 4 deletions(-)
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index d88b08a9..fa3ee896 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -63,7 +63,7 @@ bin/urweb: xml/entities.sml \
$(MLTON) $(MLTONARGS) -output $@ src/compiler.mlb
xml/entities.sml: xml/parse xml/xhtml-lat1.ent xml/xhtml-special.ent xml/xhtml-symbol.ent
- xml/parse >xml/entities.sml
+ $^ > $@
xml/parse: xml/parse.sml
$(MLTON) $(MLTONARGS) xml/parse.sml