summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Makefile.am2
-rw-r--r--xml/parse.sml4
2 files changed, 2 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index d88b08a9..fa3ee896 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -63,7 +63,7 @@ bin/urweb: xml/entities.sml \
$(MLTON) $(MLTONARGS) -output $@ src/compiler.mlb
xml/entities.sml: xml/parse xml/xhtml-lat1.ent xml/xhtml-special.ent xml/xhtml-symbol.ent
- xml/parse >xml/entities.sml
+ $^ > $@
xml/parse: xml/parse.sml
$(MLTON) $(MLTONARGS) xml/parse.sml
diff --git a/xml/parse.sml b/xml/parse.sml
index ad63c851..21256010 100644
--- a/xml/parse.sml
+++ b/xml/parse.sml
@@ -67,9 +67,7 @@ fun main () =
in
print "structure Entities = struct\n";
print "\tval all =\n";
- doFile "xml/xhtml-lat1.ent";
- doFile "xml/xhtml-special.ent";
- doFile "xml/xhtml-symbol.ent";
+ app doFile (CommandLine.arguments ());
print "\t[]\n";
print "end\n"
end