summaryrefslogtreecommitdiff
path: root/data
diff options
context:
space:
mode:
authorGravatar Patrick Griffis <tingping@tingping.se>2018-11-02 17:16:17 -0400
committerGravatar Patrick Griffis <tingping@tingping.se>2018-11-02 17:29:03 -0400
commitbccf38ab8a7cbb10ded3c7cf4cade5a4b1d8d1d3 (patch)
tree57e862c1d4d545b2ab8b16c1f72e73eed20d06e0 /data
parent820cf3576e3a01fc71c45beba7ee9e69b0c227e8 (diff)
build: Drop intltool for gettext
Diffstat (limited to 'data')
-rw-r--r--data/Makefile.am10
-rw-r--r--data/io.github.TransmissionRemoteGtk.appdata.xml.in16
-rw-r--r--data/io.github.TransmissionRemoteGtk.desktop.in4
3 files changed, 17 insertions, 13 deletions
diff --git a/data/Makefile.am b/data/Makefile.am
index 2bddf1c..ad5c5cd 100644
--- a/data/Makefile.am
+++ b/data/Makefile.am
@@ -1,15 +1,19 @@
SUBDIRS = icons
+%.desktop: %.desktop.in
+ $(AM_V_GEN)$(MSGFMT) --desktop --template $< -d $(top_srcdir)/po -o $@
+
desktop_in_files = io.github.TransmissionRemoteGtk.desktop.in
desktop_FILES = $(desktop_in_files:.desktop.in=.desktop)
-@INTLTOOL_DESKTOP_RULE@
@DESKTOP_FILE_RULES@
+%.appdata.xml: %.appdata.xml.in
+ $(AM_V_GEN)$(MSGFMT) --xml --template $< -d $(top_srcdir)/po -o $@
+
appstream_in_files = io.github.TransmissionRemoteGtk.appdata.xml.in
appstream_XML = $(appstream_in_files:.xml.in=.xml)
-@INTLTOOL_XML_RULE@
@APPSTREAM_XML_RULES@
EXTRA_DIST = $(desktop_in_files) $(appstream_in_files)
-DISTCLEANFILES = $(desktop_FILES) $(appstream_XML)
+CLEANFILES = $(desktop_FILES) $(appstream_XML)
diff --git a/data/io.github.TransmissionRemoteGtk.appdata.xml.in b/data/io.github.TransmissionRemoteGtk.appdata.xml.in
index c15279f..b1340e3 100644
--- a/data/io.github.TransmissionRemoteGtk.appdata.xml.in
+++ b/data/io.github.TransmissionRemoteGtk.appdata.xml.in
@@ -6,20 +6,20 @@
<project_license>GPL-2.0+</project_license>
<translation type="gettext">transmission-remote-gtk</translation>
<name>Transmission Remote</name>
- <_developer_name>Transmission Remote Gtk Team</_developer_name>
+ <developer_name>Transmission Remote Gtk Team</developer_name>
<summary>Remotely manage the Transmission BitTorrent client</summary>
<url type="homepage">https://github.com/transmission-remote-gtk/transmission-remote-gtk</url>
<url type="bugtracker">https://github.com/transmission-remote-gtk/transmission-remote-gtk/issues</url>
<description>
- <_p>
+ <p>
Transmission Remote Gtk allows you to remotely manage the Transmission BitTorrent client using its RPC interface.
- </_p>
- <_p>Features:</_p>
+ </p>
+ <p>Features:</p>
<ul>
- <_li>Remotely add (file/url), start, stop, remove, remove and delete, verify, reannounce torrents</_li>
- <_li>Works as a .torrent handler (eg. from a web browser)</_li>
- <_li>Set torrent properties such as speed, seed, peer limits, file priorities, add/edit/remove trackers</_li>
- <_li>Change remote settings like global limits, download directory, and connectivity preferences</_li>
+ <li>Remotely add (file/url), start, stop, remove, remove and delete, verify, reannounce torrents</li>
+ <li>Works as a .torrent handler (eg. from a web browser)</li>
+ <li>Set torrent properties such as speed, seed, peer limits, file priorities, add/edit/remove trackers</li>
+ <li>Change remote settings like global limits, download directory, and connectivity preferences</li>
</ul>
</description>
<screenshots>
diff --git a/data/io.github.TransmissionRemoteGtk.desktop.in b/data/io.github.TransmissionRemoteGtk.desktop.in
index 776a6f7..d52cd80 100644
--- a/data/io.github.TransmissionRemoteGtk.desktop.in
+++ b/data/io.github.TransmissionRemoteGtk.desktop.in
@@ -1,6 +1,6 @@
[Desktop Entry]
-_Name=Transmission Remote
-_Comment=Remotely manage the Transmission BitTorrent client
+Name=Transmission Remote
+Comment=Remotely manage the Transmission BitTorrent client
Exec=transmission-remote-gtk %U
Icon=transmission-remote-gtk
Terminal=false