summaryrefslogtreecommitdiff
path: root/data/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'data/Makefile.am')
-rw-r--r--data/Makefile.am10
1 files changed, 7 insertions, 3 deletions
diff --git a/data/Makefile.am b/data/Makefile.am
index 2bddf1c..ad5c5cd 100644
--- a/data/Makefile.am
+++ b/data/Makefile.am
@@ -1,15 +1,19 @@
SUBDIRS = icons
+%.desktop: %.desktop.in
+ $(AM_V_GEN)$(MSGFMT) --desktop --template $< -d $(top_srcdir)/po -o $@
+
desktop_in_files = io.github.TransmissionRemoteGtk.desktop.in
desktop_FILES = $(desktop_in_files:.desktop.in=.desktop)
-@INTLTOOL_DESKTOP_RULE@
@DESKTOP_FILE_RULES@
+%.appdata.xml: %.appdata.xml.in
+ $(AM_V_GEN)$(MSGFMT) --xml --template $< -d $(top_srcdir)/po -o $@
+
appstream_in_files = io.github.TransmissionRemoteGtk.appdata.xml.in
appstream_XML = $(appstream_in_files:.xml.in=.xml)
-@INTLTOOL_XML_RULE@
@APPSTREAM_XML_RULES@
EXTRA_DIST = $(desktop_in_files) $(appstream_in_files)
-DISTCLEANFILES = $(desktop_FILES) $(appstream_XML)
+CLEANFILES = $(desktop_FILES) $(appstream_XML)