summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGravatar Patrick Griffis <tingping@tingping.se>2018-11-02 17:16:17 -0400
committerGravatar Patrick Griffis <tingping@tingping.se>2018-11-02 17:29:03 -0400
commitbccf38ab8a7cbb10ded3c7cf4cade5a4b1d8d1d3 (patch)
tree57e862c1d4d545b2ab8b16c1f72e73eed20d06e0
parent820cf3576e3a01fc71c45beba7ee9e69b0c227e8 (diff)
build: Drop intltool for gettext
-rw-r--r--.gitignore8
-rw-r--r--Makefile.am9
-rwxr-xr-xautogen.sh1
-rw-r--r--configure.ac3
-rw-r--r--data/Makefile.am10
-rw-r--r--data/io.github.TransmissionRemoteGtk.appdata.xml.in16
-rw-r--r--data/io.github.TransmissionRemoteGtk.desktop.in4
-rw-r--r--po/Makevars78
-rw-r--r--po/POTFILES.in4
9 files changed, 108 insertions, 25 deletions
diff --git a/.gitignore b/.gitignore
index cef1612..b2643dd 100644
--- a/.gitignore
+++ b/.gitignore
@@ -40,9 +40,15 @@ __pycache__/
/po/POTFILES
/po/stamp-it
-/po/.intltool-merge-cache
/po/*.pot
/po/*.gmo
+/ABOUT-NLS
+/po/Rules-quot
+/po/*.sed
+/po/*.sin
+/po/*.header
+/po/Makevars.template
+/po/stamp-po
/docs/*.signals
/docs/*.types
diff --git a/Makefile.am b/Makefile.am
index bdade72..dc8f3b3 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -20,12 +20,7 @@
ACLOCAL_AMFLAGS = -I m4
AUTOMAKE_OPTIONS = foreign
DISTCHECK_CONFIGURE_FLAGS = --disable-desktop-database-update
-SUBDIRS = extern src po data
+SUBDIRS = extern src data po
-EXTRA_DIST = README.md
-
-DISTCLEANFILES = \
- intltool-extract \
- intltool-merge \
- intltool-update
+EXTRA_DIST = config.rpath README.md
diff --git a/autogen.sh b/autogen.sh
index f06f1a6..cfdc230 100755
--- a/autogen.sh
+++ b/autogen.sh
@@ -11,7 +11,6 @@ test -z "$srcdir" && srcdir=.
aclocal --install -I m4 || exit 1
libtoolize --quiet --copy || exit 1
-intltoolize --copy --automake || exit 1
autoreconf --install -Wno-portability || exit 1
if [ "$NOCONFIGURE" = "" ]; then
diff --git a/configure.ac b/configure.ac
index 8dda21d..1e27ff8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -45,7 +45,8 @@ AC_PATH_PROG([POD2MAN], [pod2man])
LT_PREREQ([2.2.0])
LT_INIT
LT_LIB_M
-IT_PROG_INTLTOOL([0.50.1])
+AM_GNU_GETTEXT_VERSION([0.19.6])
+AM_GNU_GETTEXT([external])
PKG_PROG_PKG_CONFIG([0.28])
DESKTOP_FILE
APPSTREAM_XML
diff --git a/data/Makefile.am b/data/Makefile.am
index 2bddf1c..ad5c5cd 100644
--- a/data/Makefile.am
+++ b/data/Makefile.am
@@ -1,15 +1,19 @@
SUBDIRS = icons
+%.desktop: %.desktop.in
+ $(AM_V_GEN)$(MSGFMT) --desktop --template $< -d $(top_srcdir)/po -o $@
+
desktop_in_files = io.github.TransmissionRemoteGtk.desktop.in
desktop_FILES = $(desktop_in_files:.desktop.in=.desktop)
-@INTLTOOL_DESKTOP_RULE@
@DESKTOP_FILE_RULES@
+%.appdata.xml: %.appdata.xml.in
+ $(AM_V_GEN)$(MSGFMT) --xml --template $< -d $(top_srcdir)/po -o $@
+
appstream_in_files = io.github.TransmissionRemoteGtk.appdata.xml.in
appstream_XML = $(appstream_in_files:.xml.in=.xml)
-@INTLTOOL_XML_RULE@
@APPSTREAM_XML_RULES@
EXTRA_DIST = $(desktop_in_files) $(appstream_in_files)
-DISTCLEANFILES = $(desktop_FILES) $(appstream_XML)
+CLEANFILES = $(desktop_FILES) $(appstream_XML)
diff --git a/data/io.github.TransmissionRemoteGtk.appdata.xml.in b/data/io.github.TransmissionRemoteGtk.appdata.xml.in
index c15279f..b1340e3 100644
--- a/data/io.github.TransmissionRemoteGtk.appdata.xml.in
+++ b/data/io.github.TransmissionRemoteGtk.appdata.xml.in
@@ -6,20 +6,20 @@
<project_license>GPL-2.0+</project_license>
<translation type="gettext">transmission-remote-gtk</translation>
<name>Transmission Remote</name>
- <_developer_name>Transmission Remote Gtk Team</_developer_name>
+ <developer_name>Transmission Remote Gtk Team</developer_name>
<summary>Remotely manage the Transmission BitTorrent client</summary>
<url type="homepage">https://github.com/transmission-remote-gtk/transmission-remote-gtk</url>
<url type="bugtracker">https://github.com/transmission-remote-gtk/transmission-remote-gtk/issues</url>
<description>
- <_p>
+ <p>
Transmission Remote Gtk allows you to remotely manage the Transmission BitTorrent client using its RPC interface.
- </_p>
- <_p>Features:</_p>
+ </p>
+ <p>Features:</p>
<ul>
- <_li>Remotely add (file/url), start, stop, remove, remove and delete, verify, reannounce torrents</_li>
- <_li>Works as a .torrent handler (eg. from a web browser)</_li>
- <_li>Set torrent properties such as speed, seed, peer limits, file priorities, add/edit/remove trackers</_li>
- <_li>Change remote settings like global limits, download directory, and connectivity preferences</_li>
+ <li>Remotely add (file/url), start, stop, remove, remove and delete, verify, reannounce torrents</li>
+ <li>Works as a .torrent handler (eg. from a web browser)</li>
+ <li>Set torrent properties such as speed, seed, peer limits, file priorities, add/edit/remove trackers</li>
+ <li>Change remote settings like global limits, download directory, and connectivity preferences</li>
</ul>
</description>
<screenshots>
diff --git a/data/io.github.TransmissionRemoteGtk.desktop.in b/data/io.github.TransmissionRemoteGtk.desktop.in
index 776a6f7..d52cd80 100644
--- a/data/io.github.TransmissionRemoteGtk.desktop.in
+++ b/data/io.github.TransmissionRemoteGtk.desktop.in
@@ -1,6 +1,6 @@
[Desktop Entry]
-_Name=Transmission Remote
-_Comment=Remotely manage the Transmission BitTorrent client
+Name=Transmission Remote
+Comment=Remotely manage the Transmission BitTorrent client
Exec=transmission-remote-gtk %U
Icon=transmission-remote-gtk
Terminal=false
diff --git a/po/Makevars b/po/Makevars
new file mode 100644
index 0000000..a75f13e
--- /dev/null
+++ b/po/Makevars
@@ -0,0 +1,78 @@
+# Makefile variables for PO directory in any package using GNU gettext.
+
+# Usually the message domain is the same as the package name.
+DOMAIN = $(PACKAGE)
+
+# These two variables depend on the location of this directory.
+subdir = po
+top_builddir = ..
+
+# These options get passed to xgettext.
+XGETTEXT_OPTIONS = --from-code=UTF-8 --keyword=_ --keyword=N_ --keyword=C_:1c,2 --keyword=NC_:1c,2 --keyword=g_dngettext:2,3 --add-comments
+
+# This is the copyright holder that gets inserted into the header of the
+# $(DOMAIN).pot file. Set this to the copyright holder of the surrounding
+# package. (Note that the msgstr strings, extracted from the package's
+# sources, belong to the copyright holder of the package.) Translators are
+# expected to transfer the copyright for their translations to this person
+# or entity, or to disclaim their copyright. The empty string stands for
+# the public domain; in this case the translators are expected to disclaim
+# their copyright.
+COPYRIGHT_HOLDER =
+
+# This tells whether or not to prepend "GNU " prefix to the package
+# name that gets inserted into the header of the $(DOMAIN).pot file.
+# Possible values are "yes", "no", or empty. If it is empty, try to
+# detect it automatically by scanning the files in $(top_srcdir) for
+# "GNU packagename" string.
+PACKAGE_GNU =
+
+# This is the email address or URL to which the translators shall report
+# bugs in the untranslated strings:
+# - Strings which are not entire sentences, see the maintainer guidelines
+# in the GNU gettext documentation, section 'Preparing Strings'.
+# - Strings which use unclear terms or require additional context to be
+# understood.
+# - Strings which make invalid assumptions about notation of date, time or
+# money.
+# - Pluralisation problems.
+# - Incorrect English spelling.
+# - Incorrect formatting.
+# It can be your email address, or a mailing list address where translators
+# can write to without being subscribed, or the URL of a web page through
+# which the translators can contact you.
+MSGID_BUGS_ADDRESS =
+
+# This is the list of locale categories, beyond LC_MESSAGES, for which the
+# message catalogs shall be used. It is usually empty.
+EXTRA_LOCALE_CATEGORIES =
+
+# This tells whether the $(DOMAIN).pot file contains messages with an 'msgctxt'
+# context. Possible values are "yes" and "no". Set this to yes if the
+# package uses functions taking also a message context, like pgettext(), or
+# if in $(XGETTEXT_OPTIONS) you define keywords with a context argument.
+USE_MSGCTXT = no
+
+# These options get passed to msgmerge.
+# Useful options are in particular:
+# --previous to keep previous msgids of translated messages,
+# --quiet to reduce the verbosity.
+MSGMERGE_OPTIONS =
+
+# These options get passed to msginit.
+# If you want to disable line wrapping when writing PO files, add
+# --no-wrap to MSGMERGE_OPTIONS, XGETTEXT_OPTIONS, and
+# MSGINIT_OPTIONS.
+MSGINIT_OPTIONS =
+
+# This tells whether or not to regenerate a PO file when $(DOMAIN).pot
+# has changed. Possible values are "yes" and "no". Set this to no if
+# the POT file is checked in the repository and the version control
+# program ignores timestamps.
+PO_DEPENDS_ON_POT = yes
+
+# This tells whether or not to forcibly update $(DOMAIN).pot and
+# regenerate PO files on "make dist". Possible values are "yes" and
+# "no". Set this to no if the POT file and PO files are maintained
+# externally.
+DIST_DEPENDS_ON_UPDATE_PO = no
diff --git a/po/POTFILES.in b/po/POTFILES.in
index 6d10454..0fca016 100644
--- a/po/POTFILES.in
+++ b/po/POTFILES.in
@@ -1,5 +1,5 @@
-[type: gettext/ini]data/io.github.TransmissionRemoteGtk.desktop.in
-[type: gettext/xml]data/io.github.TransmissionRemoteGtk.appdata.xml.in
+data/io.github.TransmissionRemoteGtk.desktop.in
+data/io.github.TransmissionRemoteGtk.appdata.xml.in
src/bencode.c
src/hig.c
src/json.c