summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGravatar Oleksiy <oleksiy@unity3d.com>2014-01-22 13:38:02 +0100
committerGravatar Oleksiy <oleksiy@unity3d.com>2014-01-22 13:39:58 +0100
commiteff965007b6da125da840dfb8030d6c9f057852f (patch)
tree704c7628a3edc8204a8cf75ae0e21f1e0642844e
parentde99cb57b080bb183c9540773899d13a8e9fe7ad (diff)
fixed remote playlist loading regression causing crash
-rw-r--r--PORTABLE_VERSION2
-rw-r--r--configure.ac2
-rw-r--r--streamer.c1
3 files changed, 2 insertions, 3 deletions
diff --git a/PORTABLE_VERSION b/PORTABLE_VERSION
index 084c97be..d64531f1 100644
--- a/PORTABLE_VERSION
+++ b/PORTABLE_VERSION
@@ -1 +1 @@
-0.6.1-rc1
+devel
diff --git a/configure.ac b/configure.ac
index 0cbe52d3..4908486c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,5 +1,5 @@
dnl Process this file with autoconf to produce a configure script.
-AC_INIT([deadbeef], [0.6.1-rc1])
+AC_INIT([deadbeef], [devel])
AC_CONFIG_HEADER(config.h)
diff --git a/streamer.c b/streamer.c
index 23131de2..97221374 100644
--- a/streamer.c
+++ b/streamer.c
@@ -1011,7 +1011,6 @@ streamer_set_current (playItem_t *it) {
pl_item_unref (i);
i = next;
}
- pl_item_unref ((playItem_t*)m3u);
plt_free (plt);
if (res == 0) {
// succeeded -- playing now