summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGravatar Alexey Yakovenko <waker@users.sourceforge.net>2014-01-21 21:37:31 +0100
committerGravatar Alexey Yakovenko <waker@users.sourceforge.net>2014-01-21 21:37:31 +0100
commitde99cb57b080bb183c9540773899d13a8e9fe7ad (patch)
treec4c5009ee3261e2072535ed33de152cc745c7b81
parent1fc4f85ea0c09dee2910d52539b864a3379a1abe (diff)
0.6.1-rc1
-rw-r--r--ChangeLog33
-rw-r--r--PORTABLE_VERSION2
-rw-r--r--configure.ac2
3 files changed, 35 insertions, 2 deletions
diff --git a/ChangeLog b/ChangeLog
index ca262e72..4b3f0f51 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,36 @@
+version 0.6.1
+ fixed crash in AAC plugin when mp4 file reports 0 samples (e.g. radio rips)
+ fixed libsupc++ linking issues
+ fixed support for gcc<4.5
+ changed description of hotkeys plugin in configure
+ fixed 100% CPU load issues with certain hotkeys
+ fixed opening files from command line into default playlist
+ don't allow spawning multiple instances of converter
+ fixed EQ drawing past the bottom margin
+ fixed progress dialog while loading playlists
+ fixed M3UINF parser
+ reverted MP3 bugfixes which introduced incorrect duration calculation
+ fixed ungrabbing deleted global hotkeys
+ added config option to help debug buffering/streaming
+ ffmpeg plugin can now handle dynamic data format changes
+ fixed rare buffering problem which was causing stuttering for some users
+ fixed running without X and/or without GUI plugin
+ fixed mp3 duration rounding bug
+ fixed incorrect scroll/cursor after deleting playlists
+ added support for loading plugins from ~/.local/lib{32|64}/deadbeef, depending on running deadbeef build version
+ fixed bug imposing 256 byte limit on file pathes in archives
+ fixed column autoresize issues
+ removed libstdc++ hacks from C++ plugins
+ fixed "Remove from disk" menu item not being hidden by corresponding option
+ fixed applying "Pin group titles" config on startup (patch from Christian Boxdörfer)
+ improved charset detection in CUE files, not longer allowing invalid utf-8 to go through
+ paused network streams don't attempt to prebuffer until played
+ unpausing network streams always restarts them
+ prevent loading playlists from archives (treat them like folders)
+ hide the "Hotkeys" tab from preferences if hotkeys plugin is not available
+ don't build shellexecui if not building shellexec
+ fixed memleak when drag-dropping pls/m3u playlists from file managers
+
version 0.6.0
gui layout designer, with a set of widgets to choose from (View -> Design mode, then use right click)
new API for creating GUI extension plugins
diff --git a/PORTABLE_VERSION b/PORTABLE_VERSION
index d64531f1..084c97be 100644
--- a/PORTABLE_VERSION
+++ b/PORTABLE_VERSION
@@ -1 +1 @@
-devel
+0.6.1-rc1
diff --git a/configure.ac b/configure.ac
index 4908486c..0cbe52d3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,5 +1,5 @@
dnl Process this file with autoconf to produce a configure script.
-AC_INIT([deadbeef], [devel])
+AC_INIT([deadbeef], [0.6.1-rc1])
AC_CONFIG_HEADER(config.h)