summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGravatar MichalMoskal <unknown>2009-12-17 01:12:56 +0000
committerGravatar MichalMoskal <unknown>2009-12-17 01:12:56 +0000
commitfa8cb4c335668f180fa2c181ca6bb1ad87b54c4a (patch)
tree196fd3c1d78ed3c4c7cd7516ab5c6a7e7a01e8ca
parent493f1758d8ba70ead41c6951b5dfa223032ac83c (diff)
Add makefile for running tests, allows "make -j4" to utilize multiple cores.
Change the runtest.bat to report the testname in "succeeded/failed" message, so one can make sense of the multiple core output.
-rw-r--r--Test/Makefile17
-rw-r--r--Test/runtest.bat4
2 files changed, 19 insertions, 2 deletions
diff --git a/Test/Makefile b/Test/Makefile
new file mode 100644
index 00000000..dab13bd2
--- /dev/null
+++ b/Test/Makefile
@@ -0,0 +1,17 @@
+TESTS_FILE = alltests.txt
+LONG = $(shell awk '{ if (tolower($$2) ~ /^long$$/) print $$1 }' $(TESTS_FILE))
+NORMAL = $(shell awk '{ if (tolower($$2) ~ /^use$$/) print $$1 }' $(TESTS_FILE))
+TESTS = $(NORMAL)
+
+all: $(addprefix run-, $(TESTS))
+ @echo ALL OK
+
+
+show:
+ @echo $(TESTS)
+
+long:
+ $(MAKE) TESTS="$(NORMAL) $(LONG)" all
+
+run-%:
+ @./runtest.bat $*
diff --git a/Test/runtest.bat b/Test/runtest.bat
index 424ede10..c86e4427 100644
--- a/Test/runtest.bat
+++ b/Test/runtest.bat
@@ -8,11 +8,11 @@ if not exist runtest.bat goto noRunTest
call runtest.bat -nologo -logPrefix:%1 %2 %3 %4 %5 %6 %7 %8 %9 > Output
fc /W Answer Output > nul
if not errorlevel 1 goto passTest
-echo FAILED
+echo %1 FAILED
goto errorEnd
:passTest
-echo Succeeded
+echo %1 Succeeded
goto end
:noDirSpecified