summaryrefslogtreecommitdiff
path: root/Test/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Test/Makefile')
-rw-r--r--Test/Makefile17
1 files changed, 17 insertions, 0 deletions
diff --git a/Test/Makefile b/Test/Makefile
new file mode 100644
index 00000000..dab13bd2
--- /dev/null
+++ b/Test/Makefile
@@ -0,0 +1,17 @@
+TESTS_FILE = alltests.txt
+LONG = $(shell awk '{ if (tolower($$2) ~ /^long$$/) print $$1 }' $(TESTS_FILE))
+NORMAL = $(shell awk '{ if (tolower($$2) ~ /^use$$/) print $$1 }' $(TESTS_FILE))
+TESTS = $(NORMAL)
+
+all: $(addprefix run-, $(TESTS))
+ @echo ALL OK
+
+
+show:
+ @echo $(TESTS)
+
+long:
+ $(MAKE) TESTS="$(NORMAL) $(LONG)" all
+
+run-%:
+ @./runtest.bat $*