summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorGravatar Benjamin Barenblat <bbaren@google.com>2021-03-05 15:57:29 -0500
committerGravatar Benjamin Barenblat <bbaren@google.com>2021-03-05 15:57:29 -0500
commit2313d7bc2cc9110ce630548b2d892a810d34eb7d (patch)
tree58ed030107dc720a6ffca9874dbb1b9f6dd8ee4b /debian/rules
parent0159f87cfaf679f55bcc99f375a772ea3374d272 (diff)
Reenable unit tests on ppc64el
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules6
1 files changed, 5 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index 03e1a00d..b1372948 100755
--- a/debian/rules
+++ b/debian/rules
@@ -13,10 +13,14 @@
# License for the specific language governing permissions and limitations under
# the License.
+include /usr/share/dpkg/architecture.mk
+
export DEB_BUILD_MAINT_OPTIONS = hardening=+bindnow reproducible=+fixfilepath
# Unit tests aren't working on all platforms yet.
-ifeq ($(shell dpkg-architecture -qDEB_HOST_ARCH),amd64)
+ifeq ($(DEB_HOST_ARCH),amd64)
+ABSL_RUN_TESTS=ON
+else ifeq ($(DEB_HOST_ARCH),ppc64el)
ABSL_RUN_TESTS=ON
else
ABSL_RUN_TESTS=OFF