summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGravatar Benjamin Barenblat <bbaren@google.com>2021-03-05 15:57:29 -0500
committerGravatar Benjamin Barenblat <bbaren@google.com>2021-03-05 15:57:29 -0500
commit2313d7bc2cc9110ce630548b2d892a810d34eb7d (patch)
tree58ed030107dc720a6ffca9874dbb1b9f6dd8ee4b
parent0159f87cfaf679f55bcc99f375a772ea3374d272 (diff)
Reenable unit tests on ppc64el
-rw-r--r--debian/changelog1
-rw-r--r--debian/control2
-rwxr-xr-xdebian/rules6
3 files changed, 7 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index 500ef137..c8d28890 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -3,6 +3,7 @@ abseil (0~20200923.3-3) UNRELEASED; urgency=medium
* Fix "ftbfs with -march=x86-64-v3" by correcting the relevant unit
tests. (Closes: #983936)
* Disable double-double unit tests due to compiler bugs.
+ * Reenable unit tests on ppc64el.
-- Benjamin Barenblat <bbaren@debian.org> Thu, 04 Mar 2021 14:37:45 -0500
diff --git a/debian/control b/debian/control
index 7ebf70dd..ea2a5fd3 100644
--- a/debian/control
+++ b/debian/control
@@ -18,7 +18,7 @@ Maintainer: Benjamin Barenblat <bbaren@debian.org>
Build-Depends:
cmake (>= 3.5),
debhelper-compat (= 12),
- googletest (>= 1.10.0.20200926) [amd64],
+ googletest (>= 1.10.0.20200926) [amd64 ppc64el],
Rules-Requires-Root: no
Standards-Version: 4.5.1
Section: libs
diff --git a/debian/rules b/debian/rules
index 03e1a00d..b1372948 100755
--- a/debian/rules
+++ b/debian/rules
@@ -13,10 +13,14 @@
# License for the specific language governing permissions and limitations under
# the License.
+include /usr/share/dpkg/architecture.mk
+
export DEB_BUILD_MAINT_OPTIONS = hardening=+bindnow reproducible=+fixfilepath
# Unit tests aren't working on all platforms yet.
-ifeq ($(shell dpkg-architecture -qDEB_HOST_ARCH),amd64)
+ifeq ($(DEB_HOST_ARCH),amd64)
+ABSL_RUN_TESTS=ON
+else ifeq ($(DEB_HOST_ARCH),ppc64el)
ABSL_RUN_TESTS=ON
else
ABSL_RUN_TESTS=OFF