summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules6
1 files changed, 5 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index 03e1a00d..b1372948 100755
--- a/debian/rules
+++ b/debian/rules
@@ -13,10 +13,14 @@
# License for the specific language governing permissions and limitations under
# the License.
+include /usr/share/dpkg/architecture.mk
+
export DEB_BUILD_MAINT_OPTIONS = hardening=+bindnow reproducible=+fixfilepath
# Unit tests aren't working on all platforms yet.
-ifeq ($(shell dpkg-architecture -qDEB_HOST_ARCH),amd64)
+ifeq ($(DEB_HOST_ARCH),amd64)
+ABSL_RUN_TESTS=ON
+else ifeq ($(DEB_HOST_ARCH),ppc64el)
ABSL_RUN_TESTS=ON
else
ABSL_RUN_TESTS=OFF