summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorGravatar Jonathan D Reed <jdreed@mit.edu>2011-08-01 19:12:00 +0000
committerGravatar Jonathan D Reed <jdreed@mit.edu>2011-08-01 19:12:00 +0000
commit3dcb4d53b727353f84382f4c84188d1f291bb6ed (patch)
treea01f16281fc69745c42b080b56b577cff84f69c0 /debian/rules
parent9818e2cbb3f52ef353d61a51360cdc8cb06045d8 (diff)
In extra-software:
* Drop dependency on openoffice.org-java-common, since openoffice.org (which we also depend on) depends on openoffice.org-java-common * Conditionally depend on libreoffice and ship a wrapper (for now)
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules11
1 files changed, 11 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index abbd33b..6f744a4 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,10 +1,21 @@
#!/usr/bin/make -f
HAVE_ICEDTEA = $(shell apt-cache show icedtea6-plugin 2>/dev/null | grep -q '^Version:' && echo y)
+HAVE_LIBREOFFICE = $(shell apt-cache show libreoffice 2>/dev/null | grep -q '^Version:' && echo y)
ifeq ($(HAVE_ICEDTEA),y)
binary-predeb/debathena-extra-software::
echo "debathena-java-plugin=icedtea6-plugin" >> debian/debathena-extra-software.substvars
endif
+ifeq ($(HAVE_LIBREOFFICE),y)
+ install/debathena-extra-software::
+ dh_install debian/ooffice usr/bin
+ binary-predeb/debathena-extra-software::
+ echo "debathena-cool-kids-office-suite=libreoffice" >> debian/debathena-extra-software.substvars
+else
+ binary-predeb/debathena-extra-software::
+ echo "debathena-cool-kids-office-suite=openoffice.org" >> debian/debathena-extra-software.substvars
+endif
+
include /usr/share/cdbs/1/rules/debhelper.mk