summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorGravatar Jonathan D Reed <jdreed@mit.edu>2011-08-01 19:12:00 +0000
committerGravatar Jonathan D Reed <jdreed@mit.edu>2011-08-01 19:12:00 +0000
commit3dcb4d53b727353f84382f4c84188d1f291bb6ed (patch)
treea01f16281fc69745c42b080b56b577cff84f69c0 /debian
parent9818e2cbb3f52ef353d61a51360cdc8cb06045d8 (diff)
In extra-software:
* Drop dependency on openoffice.org-java-common, since openoffice.org (which we also depend on) depends on openoffice.org-java-common * Conditionally depend on libreoffice and ship a wrapper (for now)
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog8
-rw-r--r--debian/control.in2
-rwxr-xr-xdebian/ooffice16
-rwxr-xr-xdebian/rules11
4 files changed, 36 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index c34d9b2..61c04a9 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+debathena-extra-software (1.2) unstable; urgency=low
+
+ * Drop dependency on openoffice.org-java-common, since openoffice.org
+ (which we also depend on) depends on openoffice.org-java-common
+ * Conditionally depend on libreoffice and ship a wrapper (for now)
+
+ -- Jonathan Reed <jdreed@mit.edu> Mon, 01 Aug 2011 15:06:04 -0400
+
debathena-extra-software (1.1) unstable; urgency=low
* Remove dependency on wmtop and demote wmbubble to a recommendation.
diff --git a/debian/control.in b/debian/control.in
index 7d81223..6c5e7df 100644
--- a/debian/control.in
+++ b/debian/control.in
@@ -13,7 +13,7 @@ Depends: debathena-extra-software-nox,
gnome-devel,
pidgin | gaim, pidgin-encryption | gaim-encryption,
gv,
- openoffice.org, openoffice.org-java-common,
+ ${debathena-cool-kids-office-suite},
thunderbird | mozilla-thunderbird | icedove,
vim-gnome,
gnuplot,
diff --git a/debian/ooffice b/debian/ooffice
new file mode 100755
index 0000000..e6f6d2f
--- /dev/null
+++ b/debian/ooffice
@@ -0,0 +1,16 @@
+#!/bin/sh
+
+msg="OpenOffice.org has been renamed to LibreOffice. You can launch it from
+the Applications menu, in the Office category. Or you can launch it by
+typing 'soffice' in the Terminal window."
+
+if [ -n "$DISPLAY" ]; then
+ zenity --info --title="OpenOffice.org Renamed" --no-wrap --text="$msg"
+else
+ cat <<EOF
+OpenOffice.org has been renamed to LibreOffice. You can launch it from
+the Applications menu, in the Office category. Or you can launch it by
+typing 'soffice' in the Terminal window.
+EOF
+fi
+exit 0
diff --git a/debian/rules b/debian/rules
index abbd33b..6f744a4 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,10 +1,21 @@
#!/usr/bin/make -f
HAVE_ICEDTEA = $(shell apt-cache show icedtea6-plugin 2>/dev/null | grep -q '^Version:' && echo y)
+HAVE_LIBREOFFICE = $(shell apt-cache show libreoffice 2>/dev/null | grep -q '^Version:' && echo y)
ifeq ($(HAVE_ICEDTEA),y)
binary-predeb/debathena-extra-software::
echo "debathena-java-plugin=icedtea6-plugin" >> debian/debathena-extra-software.substvars
endif
+ifeq ($(HAVE_LIBREOFFICE),y)
+ install/debathena-extra-software::
+ dh_install debian/ooffice usr/bin
+ binary-predeb/debathena-extra-software::
+ echo "debathena-cool-kids-office-suite=libreoffice" >> debian/debathena-extra-software.substvars
+else
+ binary-predeb/debathena-extra-software::
+ echo "debathena-cool-kids-office-suite=openoffice.org" >> debian/debathena-extra-software.substvars
+endif
+
include /usr/share/cdbs/1/rules/debhelper.mk