aboutsummaryrefslogtreecommitdiffhomepage
path: root/third_party/boringssl/src/crypto/ec/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/boringssl/src/crypto/ec/CMakeLists.txt')
-rw-r--r--third_party/boringssl/src/crypto/ec/CMakeLists.txt36
1 files changed, 36 insertions, 0 deletions
diff --git a/third_party/boringssl/src/crypto/ec/CMakeLists.txt b/third_party/boringssl/src/crypto/ec/CMakeLists.txt
new file mode 100644
index 0000000000..38a91f89b5
--- /dev/null
+++ b/third_party/boringssl/src/crypto/ec/CMakeLists.txt
@@ -0,0 +1,36 @@
+include_directories(../../include)
+
+add_library(
+ ec
+
+ OBJECT
+
+ ec.c
+ ec_asn1.c
+ ec_key.c
+ ec_montgomery.c
+ oct.c
+ p256-64.c
+ util-64.c
+ simple.c
+ wnaf.c
+)
+
+add_executable(
+ example_mul
+
+ example_mul.c
+
+ $<TARGET_OBJECTS:test_support>
+)
+
+add_executable(
+ ec_test
+
+ ec_test.cc
+
+ $<TARGET_OBJECTS:test_support>
+)
+
+target_link_libraries(example_mul crypto)
+target_link_libraries(ec_test crypto)