summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/control2
-rwxr-xr-xdebian/rules4
2 files changed, 4 insertions, 2 deletions
diff --git a/debian/control b/debian/control
index 6c36584..f757938 100644
--- a/debian/control
+++ b/debian/control
@@ -6,7 +6,7 @@ Build-Depends: debhelper (>= 5), libc-ares-dev, libkrb5-dev (>= 1.2.2-4),
comerr-dev, ss-dev, libreadline-dev | libreadline5-dev,
libx11-dev, libxt-dev, x11proto-core-dev, libncurses5-dev,
bison, libhesiod-dev, autotools-dev, python (>= 2.5), python-central,
- autoconf, libtool
+ autoconf, libtool, automake
Build-Conflicts: autoconf2.13
Standards-Version: 3.9.2.0
Homepage: http://zephyr.1ts.org/
diff --git a/debian/rules b/debian/rules
index bc208ae..140262a 100755
--- a/debian/rules
+++ b/debian/rules
@@ -61,7 +61,9 @@ configure: configure-stamp autotools
configure-stamp:
dh_testdir
# Add here commands to configure the package.
- libtoolize -i
+ libtoolize
+ aclocal
+ automake -a || true # we only want this for install-sh
autoreconf
mkdir -p $(BUILD_VARIETALS)
$(foreach VARIETY,$(BUILD_VARIETALS),(cd $(VARIETY) && CFLAGS="-g -O" ../configure $(CONFIGURE_$(VARIETY)) $(CONFIGURE_ROOT));)