summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorGravatar Karl Ramm <kcr@1ts.org>2011-10-23 14:26:09 -0400
committerGravatar Karl Ramm <kcr@1ts.org>2011-10-23 14:36:27 -0400
commit73e32bb07a3b42f3e61b7dcdcdbef7cc70957906 (patch)
tree554ac759225d818cf7f9b59e69be46dea915d3f1 /debian
parent27f10319b58aa393c48ae663a99de06660ff0311 (diff)
See if we can't tease an install-sh out of automake
So that the packaging will still work with the libtoolize on lenny
Diffstat (limited to 'debian')
-rw-r--r--debian/control2
-rwxr-xr-xdebian/rules4
2 files changed, 4 insertions, 2 deletions
diff --git a/debian/control b/debian/control
index 6c36584..f757938 100644
--- a/debian/control
+++ b/debian/control
@@ -6,7 +6,7 @@ Build-Depends: debhelper (>= 5), libc-ares-dev, libkrb5-dev (>= 1.2.2-4),
comerr-dev, ss-dev, libreadline-dev | libreadline5-dev,
libx11-dev, libxt-dev, x11proto-core-dev, libncurses5-dev,
bison, libhesiod-dev, autotools-dev, python (>= 2.5), python-central,
- autoconf, libtool
+ autoconf, libtool, automake
Build-Conflicts: autoconf2.13
Standards-Version: 3.9.2.0
Homepage: http://zephyr.1ts.org/
diff --git a/debian/rules b/debian/rules
index bc208ae..140262a 100755
--- a/debian/rules
+++ b/debian/rules
@@ -61,7 +61,9 @@ configure: configure-stamp autotools
configure-stamp:
dh_testdir
# Add here commands to configure the package.
- libtoolize -i
+ libtoolize
+ aclocal
+ automake -a || true # we only want this for install-sh
autoreconf
mkdir -p $(BUILD_VARIETALS)
$(foreach VARIETY,$(BUILD_VARIETALS),(cd $(VARIETY) && CFLAGS="-g -O" ../configure $(CONFIGURE_$(VARIETY)) $(CONFIGURE_ROOT));)