summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorGravatar Karl Ramm <kcr@1ts.org>2011-10-23 14:26:09 -0400
committerGravatar Karl Ramm <kcr@1ts.org>2011-10-23 14:36:27 -0400
commit73e32bb07a3b42f3e61b7dcdcdbef7cc70957906 (patch)
tree554ac759225d818cf7f9b59e69be46dea915d3f1 /debian/rules
parent27f10319b58aa393c48ae663a99de06660ff0311 (diff)
See if we can't tease an install-sh out of automake
So that the packaging will still work with the libtoolize on lenny
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules4
1 files changed, 3 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index bc208ae..140262a 100755
--- a/debian/rules
+++ b/debian/rules
@@ -61,7 +61,9 @@ configure: configure-stamp autotools
configure-stamp:
dh_testdir
# Add here commands to configure the package.
- libtoolize -i
+ libtoolize
+ aclocal
+ automake -a || true # we only want this for install-sh
autoreconf
mkdir -p $(BUILD_VARIETALS)
$(foreach VARIETY,$(BUILD_VARIETALS),(cd $(VARIETY) && CFLAGS="-g -O" ../configure $(CONFIGURE_$(VARIETY)) $(CONFIGURE_ROOT));)