summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGravatar Jeffrey Hutzelman <jhutz@cmu.edu>2013-01-29 03:30:02 -0500
committerGravatar Karl Ramm <kcr@1ts.org>2013-01-31 08:07:34 -0500
commita1af8cbeeca15f01b740721a988e74ca7f48b64b (patch)
tree96c19ee16d80dcd131ef8608754c1b15aa104081 /configure.ac
parent625c4d3660c09808a926e44bfe859f049449be7c (diff)
configure: Don't demand readline, curses for libss
libss may not have direct dependencies on readline and/or curses, and those libraries may in fact not even exist. If there is a dependency, a libss shared-library won't need us to link against it in any event. While old versions of libss were normally built only as archive libraries, I have been unable to find a version of that vintage which depends on readline or curses. Newer versions ship as shared libraries, and at least one widely-ditributed implementation still has no such dependency, but does appear to be able to load libreadline dynamically if it is present at runtime. KTH's libsl, which is an enhanced but drop-in-compatible libss replacement distributed with Heimdal, does depend on their editline library. But, while libeditline is a functional replacement for readline, its API is completely different. And again, this is generally a shared-library dependency of which we need not be aware.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 7b876ae..be92879 100644
--- a/configure.ac
+++ b/configure.ac
@@ -232,10 +232,10 @@ if test "$ss" != no; then
LDFLAGS="$LDFLAGS -L$ss/lib"
fi
AC_CHECK_LIB(ss, ss_perror,
- [SS_LIBS="-lss -lreadline -lcurses"
+ [SS_LIBS="-lss"
AC_DEFINE(HAVE_SS, 1, [Define if we are building with the ss library])],
AS_IF([test "x$ss" != "xmaybe"], AC_MSG_ERROR(ss library not found)),
- -lcom_err -lreadline -lcurses)
+ -lcom_err)
SS_OBJS='${SS_OBJS}'
fi
AC_SUBST(SS_LIBS)