aboutsummaryrefslogtreecommitdiffhomepage
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 0aba6781..9f37415b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -148,4 +148,9 @@ test:
else \
echo "Skipped IPv6 tests."; \
fi
+ bin/urweb -boot -noEmacs tests/float2
+ tests/float2.exe -q -a 127.0.0.1 & echo $$! >$(TESTPID)
+ sleep 1
+ (curl -s 'http://localhost:8080/main' | grep -Fq 0.6) || (kill `cat $(TESTPID)`; echo "Test 'float2' failed"; /bin/false)
+ kill `cat $(TESTPID)`
echo Tests succeeded.