aboutsummaryrefslogtreecommitdiffhomepage
path: root/src/c/Makefile.am
diff options
context:
space:
mode:
authorGravatar Anders Kaseorg <andersk@mit.edu>2013-11-22 09:36:14 -0500
committerGravatar Anders Kaseorg <andersk@mit.edu>2013-11-22 09:36:14 -0500
commit9e813736bd6839d308850ecb90f0d9879232ef9f (patch)
tree97f00f341bfce7c33604e4f0df24d01515d66593 /src/c/Makefile.am
parente5b80fe0886a6753cf2cad4cb5e1d34fc2761472 (diff)
Allow building in a separate build directory
Signed-off-by: Anders Kaseorg <andersk@mit.edu> --- Makefile.am | 30 +++--- src/c/Makefile.am | 2 +- src/compiler.mlb | 2 +- src/sources | 302 +++++++++++++++++++++++++++--------------------------- 4 files changed, 168 insertions(+), 168 deletions(-)
Diffstat (limited to 'src/c/Makefile.am')
-rw-r--r--src/c/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/c/Makefile.am b/src/c/Makefile.am
index 4cb3cdbc..fdc033f6 100644
--- a/src/c/Makefile.am
+++ b/src/c/Makefile.am
@@ -6,7 +6,7 @@ liburweb_cgi_la_SOURCES = cgi.c
liburweb_fastcgi_la_SOURCES = fastcgi.c
liburweb_static_la_SOURCES = static.c
-AM_CPPFLAGS = -I../../include/urweb $(OPENSSL_INCLUDES)
+AM_CPPFLAGS = -I$(srcdir)/../../include/urweb $(OPENSSL_INCLUDES)
AM_CFLAGS = -Wimplicit -Wall -Werror -Wno-format-security -Wno-deprecated-declarations $(PTHREAD_CFLAGS)
liburweb_la_LDFLAGS = $(AM_LDFLAGS) $(OPENSSL_LDFLAGS)
liburweb_la_LIBADD = $(PTHREAD_LIBS) -lm $(OPENSSL_LIBS)