aboutsummaryrefslogtreecommitdiffhomepage
path: root/configure.ac
diff options
context:
space:
mode:
authorGravatar Adam Chlipala <adam@chlipala.net>2011-08-04 17:06:50 -0400
committerGravatar Adam Chlipala <adam@chlipala.net>2011-08-04 17:06:50 -0400
commit64f43be321e5ad4bef303831a589e1bd415e8673 (patch)
tree982f9f5673e512568490930bf5aff4f4bca9813e /configure.ac
parent7e42ca73d84c1938c881aa103a9c5bf40a9f1bfb (diff)
Configure correct C compiler options for Pthreads
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 62f0c3aa..970ceee0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -7,6 +7,8 @@ AC_PROG_LIBTOOL()
AC_CONFIG_MACRO_DIR([m4])
AC_CONFIG_HEADERS([config.h])
+AX_PTHREAD([echo >/dev/null], [echo "Your C compiler does not support POSIX threads."; exit 1])
+
AX_CHECK_OPENSSL([echo >/dev/null], [echo "You must install OpenSSL development files."; exit 1])
AC_CHECK_PROG(MLTON, mlton, yes, [])
@@ -94,6 +96,8 @@ AC_SUBST(PGHEADER)
AC_SUBST(MSHEADER)
AC_SUBST(SQHEADER)
AC_SUBST(VERSION)
+AC_SUBST(PTHREAD_CFLAGS)
+AC_SUBST(PTHREAD_LIBS)
AC_CONFIG_FILES([
Makefile