aboutsummaryrefslogtreecommitdiffhomepage
path: root/Makefile.am
diff options
context:
space:
mode:
authorGravatar Adam Chlipala <adam@chlipala.net>2017-08-11 19:38:43 -0400
committerGravatar Adam Chlipala <adam@chlipala.net>2017-08-11 19:38:43 -0400
commit4b7939d2fef1d8ef02ff761ade62cc220ab248cf (patch)
treee9a3811f6a763bd81522fff4a8d3c4631c4a34e7 /Makefile.am
parent9fdb50d8ecc7782ae73472b9d943a24a304d0191 (diff)
parentf814fd699dc707e810c996062370ee787863d926 (diff)
Merge branch 'master' of ssh://hnf.impredicative.com:/home/adamc/git-root/urweb
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 33bf4e7c..f0392de0 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -123,7 +123,7 @@ test:
bin/urweb -boot -noEmacs -dbms sqlite -db $(TESTDB) -demo /Demo demo
rm -f $(TESTDB)
sqlite3 $(TESTDB) < demo/demo.sql
- demo/demo.exe -a 127.0.0.1 & echo $$! > $(TESTPID)
+ demo/demo.exe -q -a 127.0.0.1 & echo $$! > $(TESTPID)
sleep 1
(curl -s 'http://localhost:8080/Demo/Hello/main' | diff tests/hello.html -) || (kill `cat $(TESTPID)`; echo "Test 'Hello' failed"; /bin/false)
(curl -s 'http://localhost:8080/Demo/Crud1/create?A=1&B=2&C=3&D=4' | diff tests/crud1.html -) || (kill `cat $(TESTPID)`; echo "Test 'Crud1' failed"; /bin/false)
@@ -133,7 +133,7 @@ test:
echo "Running IPv6 tests."; \
rm -f $(TESTDB); \
sqlite3 $(TESTDB) < demo/demo.sql; \
- demo/demo.exe -A ::1 & echo $$! > $(TESTPID); \
+ demo/demo.exe -q -A ::1 & echo $$! > $(TESTPID); \
sleep 1; \
(curl -g -6 -s 'http://[::1]:8080/Demo/Hello/main' | diff tests/hello.html -) || (kill `cat $(TESTPID)`; echo "Test 'Hello' failed"; /bin/false); \
(curl -g -6 -s 'http://[::1]:8080/Demo/Crud1/create?A=1&B=2&C=3&D=4' | diff tests/crud1.html -) || (kill `cat $(TESTPID)`; echo "Test 'Crud1' failed"; /bin/false); \