summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGravatar Benjamin Barenblat <bbaren@mit.edu>2015-07-28 10:38:10 -0400
committerGravatar Benjamin Barenblat <bbaren@mit.edu>2015-07-28 10:38:10 -0400
commit2f6799a42360a995b665244b922ebd3b2275c839 (patch)
tree23102228a85e96561f1ce20c5321d31b573b94d7 /configure.ac
parenta8b108619083c2088269ea8071c7958f277ed41f (diff)
Replace my bounds-checked numeric conversion with Boost’s
Boost provides numeric_cast, which is much better than what I was using for safe numeric type conversion. This does introduce a Boost dependency, but that tends to be true of most nontrivial C++ programs, so it’s pretty reasonable.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 9140509..763b8e4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -24,6 +24,10 @@ AC_CONFIG_HEADERS([config.h])
AC_PROG_CXX([clang++])
AX_CXX_COMPILE_STDCXX_11([noext], [mandatory])
+AX_BOOST_BASE([1.48.0],
+ [],
+ [AC_MSG_FAILURE([Boost is required])])
+
AC_CHECK_HEADERS([urweb/urweb_cpp.h],
[],
[AC_MSG_FAILURE([Ur/Web headers are required])])