summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGravatar Benjamin Barenblat <bbaren@mit.edu>2015-07-27 17:03:43 -0400
committerGravatar Benjamin Barenblat <bbaren@mit.edu>2015-07-27 17:03:43 -0400
commita8b108619083c2088269ea8071c7958f277ed41f (patch)
tree2bd68e215161d64e34cce66863ab8c0ebd1d44d2 /configure.ac
parenta6c2ac566bd749c14a29f7d8d9d2d4898b1d49de (diff)
Rework to use the C++11 regex library
Switch to using the C++11 regex library for better portability and ease of use. As an added bonus, this should make it easier to implement regex substitution.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 0 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index a9c1c74..9140509 100644
--- a/configure.ac
+++ b/configure.ac
@@ -24,10 +24,6 @@ AC_CONFIG_HEADERS([config.h])
AC_PROG_CXX([clang++])
AX_CXX_COMPILE_STDCXX_11([noext], [mandatory])
-AC_CHECK_HEADERS([regex.h],
- [],
- [AC_MSG_FAILURE([a POSIX-compatible regex.h is required])])
-
AC_CHECK_HEADERS([urweb/urweb_cpp.h],
[],
[AC_MSG_FAILURE([Ur/Web headers are required])])