aboutsummaryrefslogtreecommitdiffhomepage
path: root/benchmarks/Makefile.am
diff options
context:
space:
mode:
authorGravatar BSBandme <chongyilun250@sina.com>2018-03-14 07:03:44 -0700
committerGravatar BSBandme <chongyilun250@sina.com>2018-03-14 07:03:44 -0700
commit501c13f65a0093b61d95e16e8941cd3b456c41a0 (patch)
tree2b89b69c153465d52953b35744716dd49ce66fb6 /benchmarks/Makefile.am
parent6d2c6a0099e75eddacb8289053dd1cb96fc60368 (diff)
Rewrite go_benchmark
Diffstat (limited to 'benchmarks/Makefile.am')
-rw-r--r--benchmarks/Makefile.am5
1 files changed, 1 insertions, 4 deletions
diff --git a/benchmarks/Makefile.am b/benchmarks/Makefile.am
index f0cb9402..3de0e380 100644
--- a/benchmarks/Makefile.am
+++ b/benchmarks/Makefile.am
@@ -288,10 +288,7 @@ go-benchmark: go_protoc_middleman go_protoc_middleman2
@echo "Writing shortcut script go-benchmark..."
@echo '#! /bin/sh' > go-benchmark
@echo 'mkdir tmp_cc && mv *.cc tmp_cc' >> go-benchmark
- @echo 'for file in $$@; do' >> go-benchmark
- @echo ' echo "Testing go benchmark for data file: $$file";' >> go-benchmark
- @echo ' go test -bench=. -- $$file;' >> go-benchmark
- @echo 'done' >> go-benchmark
+ @echo 'go test -bench=. -- $$@' >> go-benchmark
@echo 'mv tmp_cc/* . && rm -rf tmp_cc' >> go-benchmark
@chmod +x go-benchmark