aboutsummaryrefslogtreecommitdiffhomepage
path: root/bindings/python/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'bindings/python/setup.py')
-rw-r--r--bindings/python/setup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/bindings/python/setup.py b/bindings/python/setup.py
index 286fd196..2e58dab1 100644
--- a/bindings/python/setup.py
+++ b/bindings/python/setup.py
@@ -7,7 +7,7 @@ from distutils.core import setup
# get the notmuch version number without importing the notmuch module
version_file = os.path.join(os.path.dirname(os.path.abspath(__file__)),
'notmuch', 'version.py')
-execfile(version_file)
+exec(compile(open(version_file).read(), version_file, 'exec'))
assert __VERSION__, 'Failed to read the notmuch binding version number'
setup(name='notmuch',