aboutsummaryrefslogtreecommitdiffhomepage
path: root/bindings/python/setup.py
diff options
context:
space:
mode:
authorGravatar Justus Winter <4winter@informatik.uni-hamburg.de>2011-12-14 11:58:19 +0100
committerGravatar Sebastian Spaeth <Sebastian@SSpaeth.de>2012-01-02 16:06:59 +0100
commit676ce952d3a5d394d15b11a8292e4a4ac2bdd7c8 (patch)
tree807de69c0b77accfda01db6fb340ecc3c97c4b93 /bindings/python/setup.py
parent442d405ad301bd0bc9dc1d385c21f943ba743308 (diff)
py3k: The execfile built-in has been removed in python 3
Diffstat (limited to 'bindings/python/setup.py')
-rw-r--r--bindings/python/setup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/bindings/python/setup.py b/bindings/python/setup.py
index 286fd196..2e58dab1 100644
--- a/bindings/python/setup.py
+++ b/bindings/python/setup.py
@@ -7,7 +7,7 @@ from distutils.core import setup
# get the notmuch version number without importing the notmuch module
version_file = os.path.join(os.path.dirname(os.path.abspath(__file__)),
'notmuch', 'version.py')
-execfile(version_file)
+exec(compile(open(version_file).read(), version_file, 'exec'))
assert __VERSION__, 'Failed to read the notmuch binding version number'
setup(name='notmuch',