aboutsummaryrefslogtreecommitdiffhomepage
path: root/debian/rules
diff options
context:
space:
mode:
authorGravatar David Bremner <bremner@debian.org>2013-01-16 08:17:19 -0400
committerGravatar David Bremner <bremner@debian.org>2013-01-16 08:52:05 -0400
commit89a58f39d07f07483ceff350fb065f29654fae1c (patch)
treeb3e26b3c9b827e176e1853dcd3110c4ab670c103 /debian/rules
parentae773ad6aa4a3c8c3b3bf1905f86b1b195875895 (diff)
debian: add python 3 bindings
This patch is due to Jakub Wilk <jwilk@debian.org>. It does add a build depend on python3 for people using the "make debian-snapshot" target.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules7
1 files changed, 6 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index 8e303538..c4e3930d 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,7 +1,9 @@
#!/usr/bin/make -f
+python3_all = py3versions -s | xargs -n1 | xargs -t -I {} env {}
+
%:
- dh $@ --with python2
+ dh $@ --with python2,python3
override_dh_auto_configure:
dh_auto_configure -- --emacslispdir=/usr/share/emacs/site-lisp/notmuch
@@ -9,13 +11,16 @@ override_dh_auto_configure:
override_dh_auto_build:
dh_auto_build
dh_auto_build --sourcedirectory bindings/python
+ cd bindings/python && $(python3_all) setup.py build
$(MAKE) -C contrib/notmuch-mutt
override_dh_auto_clean:
dh_auto_clean
dh_auto_clean --sourcedirectory bindings/python
+ cd bindings/python && $(python3_all) setup.py clean -a
$(MAKE) -C contrib/notmuch-mutt clean
override_dh_auto_install:
dh_auto_install
dh_auto_install --sourcedirectory bindings/python
+ cd bindings/python && $(python3_all) setup.py install --install-layout=deb --root=$(CURDIR)/debian/tmp