aboutsummaryrefslogtreecommitdiffhomepage
path: root/debian
diff options
context:
space:
mode:
authorGravatar David Bremner <bremner@debian.org>2013-01-16 08:17:19 -0400
committerGravatar David Bremner <bremner@debian.org>2013-01-16 08:52:05 -0400
commit89a58f39d07f07483ceff350fb065f29654fae1c (patch)
treeb3e26b3c9b827e176e1853dcd3110c4ab670c103 /debian
parentae773ad6aa4a3c8c3b3bf1905f86b1b195875895 (diff)
debian: add python 3 bindings
This patch is due to Jakub Wilk <jwilk@debian.org>. It does add a build depend on python3 for people using the "make debian-snapshot" target.
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog4
-rw-r--r--debian/control14
-rw-r--r--debian/python-notmuch.install2
-rwxr-xr-xdebian/rules7
4 files changed, 24 insertions, 3 deletions
diff --git a/debian/changelog b/debian/changelog
index f4925a13..40b76951 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -4,8 +4,10 @@ notmuch (0.15~rc1-1) experimental; urgency=low
* Change priority to optional (Closes: #687217).
* Remove Dm-Upload-Allowed field, as this is no longer used by
Debian.
+ * Add python3 bindings, thanks to Jakub Wilk (Closes:
+ #683515).
- -- David Bremner <bremner@debian.org> Mon, 07 Jan 2013 21:40:52 -0400
+ -- David Bremner <bremner@debian.org> Wed, 16 Jan 2013 08:25:02 -0400
notmuch (0.14-1) experimental; urgency=low
diff --git a/debian/control b/debian/control
index 75b55a5c..5bb0d051 100644
--- a/debian/control
+++ b/debian/control
@@ -14,6 +14,7 @@ Build-Depends:
libtalloc-dev,
libz-dev,
python-all (>= 2.6.6-3~),
+ python3-all (>= 3.1.2-7~),
emacs23-nox | emacs23 (>=23~) | emacs23-lucid (>=23~) |
emacs24-nox | emacs24 (>=24~) | emacs24-lucid (>=24~),
gdb,
@@ -75,6 +76,19 @@ Description: python interface to the notmuch mail search and index library
This package provides a Python interface to the notmuch
functionality, directly interfacing with a shared notmuch library.
+Package: python3-notmuch
+Architecture: all
+Section: python
+Depends: ${misc:Depends}, ${python3:Depends}, libnotmuch3
+Description: Python 3 interface to the notmuch mail search and index library
+ Notmuch is a system for indexing, searching, reading, and tagging
+ large collections of email messages in maildir or mh format. It uses
+ the Xapian library to provide fast, full-text search with a very
+ convenient search syntax.
+ .
+ This package provides a Python 3 interface to the notmuch
+ functionality, directly interfacing with a shared notmuch library.
+
Package: notmuch-emacs
Architecture: all
Section: mail
diff --git a/debian/python-notmuch.install b/debian/python-notmuch.install
index 607c0659..b2cc1360 100644
--- a/debian/python-notmuch.install
+++ b/debian/python-notmuch.install
@@ -1 +1 @@
-usr/lib/python*
+usr/lib/python2*
diff --git a/debian/rules b/debian/rules
index 8e303538..c4e3930d 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,7 +1,9 @@
#!/usr/bin/make -f
+python3_all = py3versions -s | xargs -n1 | xargs -t -I {} env {}
+
%:
- dh $@ --with python2
+ dh $@ --with python2,python3
override_dh_auto_configure:
dh_auto_configure -- --emacslispdir=/usr/share/emacs/site-lisp/notmuch
@@ -9,13 +11,16 @@ override_dh_auto_configure:
override_dh_auto_build:
dh_auto_build
dh_auto_build --sourcedirectory bindings/python
+ cd bindings/python && $(python3_all) setup.py build
$(MAKE) -C contrib/notmuch-mutt
override_dh_auto_clean:
dh_auto_clean
dh_auto_clean --sourcedirectory bindings/python
+ cd bindings/python && $(python3_all) setup.py clean -a
$(MAKE) -C contrib/notmuch-mutt clean
override_dh_auto_install:
dh_auto_install
dh_auto_install --sourcedirectory bindings/python
+ cd bindings/python && $(python3_all) setup.py install --install-layout=deb --root=$(CURDIR)/debian/tmp