aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Hoa Dinh <dvh@google.com>2014-11-12 13:04:18 -0800
committerGravatar Hoa Dinh <dvh@google.com>2014-11-12 13:04:18 -0800
commit73b2eb690b8d163527c93771837459c624c1b0fa (patch)
tree75d7ddf66842c9b1f95f3aa8f901194df8392d59 /CMakeLists.txt
parent8c6444bd77ac04a8182f83c2e346247418caec6e (diff)
Build for Linux
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 6 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 542d778b..7e66aa16 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,5 +1,4 @@
cmake_minimum_required (VERSION 2.6)
-find_package(PkgConfig)
project (mailcore2)
IF(APPLE)
@@ -7,5 +6,10 @@ IF(APPLE)
set(CMAKE_EXE_LINKER_FLAGS "-lc++ -stdlib=libc++")
ENDIF()
+IF(${CMAKE_SYSTEM_NAME} MATCHES "Linux")
+ find_package(PkgConfig)
+ENDIF()
+
add_subdirectory (src)
- add_subdirectory (tests)
+add_subdirectory (tests)
+