aboutsummaryrefslogtreecommitdiff
path: root/kernel/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'kernel/configure.ac')
-rw-r--r--kernel/configure.ac9
1 files changed, 8 insertions, 1 deletions
diff --git a/kernel/configure.ac b/kernel/configure.ac
index eb8a4fa..115c428 100644
--- a/kernel/configure.ac
+++ b/kernel/configure.ac
@@ -1,4 +1,4 @@
-AC_INIT(fuse-kernel, 2.7.0-pre0)
+AC_INIT(fuse-kernel, 2.7.0-pre1)
AC_CONFIG_HEADERS([config.h])
AC_PROG_INSTALL
@@ -193,6 +193,13 @@ if test "$ENABLE_FUSE_MODULE" = y; then
else
AC_MSG_RESULT([no])
fi
+ AC_MSG_CHECKING([if kernel has BLOCK option ])
+ if test -f $kernelsrc/block/Kconfig && egrep -wq "config *BLOCK" $kernelsrc/block/Kconfig; then
+ AC_DEFINE(HAVE_CONFIG_BLOCK, 1, [kernel has BLOCK option])
+ AC_MSG_RESULT([yes])
+ else
+ AC_MSG_RESULT([no])
+ fi
isuml=no
KERNELMAKE_PARAMS=