aboutsummaryrefslogtreecommitdiff
path: root/util/Makefile.am
diff options
context:
space:
mode:
authorGravatar Miklos Szeredi <miklos@szeredi.hu>2006-10-08 15:41:20 +0000
committerGravatar Miklos Szeredi <miklos@szeredi.hu>2006-10-08 15:41:20 +0000
commit7e7fa1fb9429adf2061670c97ce30a39685daadd (patch)
tree88941ecf6c34d5581eb92a6aa479aae7fcc662c1 /util/Makefile.am
parentff1e0d476dd531bb32fc5d132985223fb48e463f (diff)
fixes
Diffstat (limited to 'util/Makefile.am')
-rw-r--r--util/Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/util/Makefile.am b/util/Makefile.am
index d963e81..6572afe 100644
--- a/util/Makefile.am
+++ b/util/Makefile.am
@@ -1,10 +1,12 @@
## Process this file with automake to produce Makefile.in
+AM_CPPFLAGS = -D_FILE_OFFSET_BITS=64
bin_PROGRAMS = fusermount ulockmgr_server
fusermount_SOURCES = fusermount.c
ulockmgr_server_SOURCES = ulockmgr_server.c
+ulockmgr_server_CPPFLAGS = -D_FILE_OFFSET_BITS=64 -D_REENTRANT
ulockmgr_server_LDFLAGS = -pthread
install-exec-hook:
@@ -34,11 +36,11 @@ install-exec-local:
install-data-local:
$(mkdir_p) $(DESTDIR)$(UDEV_RULES_PATH)
- $(INSTALL_DATA) $(srcdir)/udev.rules $(DESTDIR)$(UDEV_RULES_PATH)/60-fuse.rules
+ $(INSTALL_DATA) $(srcdir)/udev.rules $(DESTDIR)$(UDEV_RULES_PATH)/99-fuse.rules
uninstall-local:
rm -f $(DESTDIR)$(MOUNT_FUSE_PATH)/mount.fuse
- rm -f $(DESTDIR)$(UDEV_RULES_PATH)/60-fuse.rules
+ rm -f $(DESTDIR)$(UDEV_RULES_PATH)/99-fuse.rules
rm -f $(DESTDIR)$(INIT_D_PATH)/fuse
@if test -x /usr/sbin/update-rc.d; then \
echo "/usr/sbin/update-rc.d fuse remove"; \