aboutsummaryrefslogtreecommitdiff
path: root/util/Makefile.am
diff options
context:
space:
mode:
authorGravatar Miklos Szeredi <miklos@szeredi.hu>2006-10-28 07:59:22 +0000
committerGravatar Miklos Szeredi <miklos@szeredi.hu>2006-10-28 07:59:22 +0000
commit10d03ed9c381436d06252ab440bc2e910e7e755b (patch)
tree13fe3b8295e89b100b825bfd533cbc2e332e439d /util/Makefile.am
parente414a2ff2cc5ba3bf618a3674a0a0a8408ad0470 (diff)
build/install fixes + add bug reporting instructions to README
Diffstat (limited to 'util/Makefile.am')
-rw-r--r--util/Makefile.am12
1 files changed, 6 insertions, 6 deletions
diff --git a/util/Makefile.am b/util/Makefile.am
index 6572afe..dcd69f6 100644
--- a/util/Makefile.am
+++ b/util/Makefile.am
@@ -14,8 +14,8 @@ install-exec-hook:
-chmod u+s $(DESTDIR)$(bindir)/fusermount
@if test ! -e $(DESTDIR)/dev/fuse; then \
$(mkdir_p) $(DESTDIR)/dev; \
- echo "mknod $(DESTDIR)/dev/fuse -m 0666 c 10 229"; \
- mknod $(DESTDIR)/dev/fuse -m 0666 c 10 229; \
+ echo "mknod $(DESTDIR)/dev/fuse -m 0666 c 10 229 || true"; \
+ mknod $(DESTDIR)/dev/fuse -m 0666 c 10 229 || true; \
fi
EXTRA_DIST = mount.fuse udev.rules init_script
@@ -30,8 +30,8 @@ install-exec-local:
$(mkdir_p) $(DESTDIR)$(INIT_D_PATH)
$(INSTALL_PROGRAM) $(srcdir)/init_script $(DESTDIR)$(INIT_D_PATH)/fuse
@if test -x /usr/sbin/update-rc.d; then \
- echo "/usr/sbin/update-rc.d fuse start 34 S . start 41 0 6 ."; \
- /usr/sbin/update-rc.d fuse start 34 S . start 41 0 6 .; \
+ echo "/usr/sbin/update-rc.d fuse start 34 S . start 41 0 6 . || true"; \
+ /usr/sbin/update-rc.d fuse start 34 S . start 41 0 6 . || true; \
fi
install-data-local:
@@ -43,6 +43,6 @@ uninstall-local:
rm -f $(DESTDIR)$(UDEV_RULES_PATH)/99-fuse.rules
rm -f $(DESTDIR)$(INIT_D_PATH)/fuse
@if test -x /usr/sbin/update-rc.d; then \
- echo "/usr/sbin/update-rc.d fuse remove"; \
- /usr/sbin/update-rc.d fuse remove; \
+ echo "/usr/sbin/update-rc.d fuse remove || true"; \
+ /usr/sbin/update-rc.d fuse remove || true; \
fi