aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorGravatar Tomohiro Kusumi <kusumi.tomohiro@gmail.com>2018-03-29 04:32:59 +0900
committerGravatar Nikolaus Rath <Nikolaus@rath.org>2018-03-28 20:32:59 +0100
commit72ab7172b8de822215cea644b148df5eacb8aa0a (patch)
tree04051d535d459419e50b6d01959173504c95b4fb /meson.build
parent03515bbb3092da9b3c2c6a267de90f9f0dcbdb29 (diff)
Fix build error on DragonFlyBSD (sync with other *BSD) (#240)
DragonFlyBSD has no "bsd" in uname, so add 'dragonfly' to conditionals. -- e.g. uname(1) in DragonFlyBSD [root@ ~]# uname DragonFly [root@ ~]# python -c "import sys; print(sys.platform)" dragonfly5
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 53a3425..b16c51b 100644
--- a/meson.build
+++ b/meson.build
@@ -93,7 +93,7 @@ thread_dep = dependency('threads')
# Read build files from sub-directories
#
subdirs = [ 'lib', 'include', 'example', 'doc', 'test' ]
-if not platform.endswith('bsd')
+if not platform.endswith('bsd') and platform != 'dragonfly'
subdirs += 'util'
endif
foreach n : subdirs