aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorGravatar Nikolaus Rath <Nikolaus@rath.org>2017-03-15 16:52:39 -0700
committerGravatar Nikolaus Rath <Nikolaus@rath.org>2017-03-15 16:52:39 -0700
commit4b58635d16791013e36d761313bec5c247eec841 (patch)
tree35a4ba916e847165fc04ae46dfb3861305758aab /meson.build
parentc3d30f931a1bfd201b30eb3a43ac1b7021fb4ce6 (diff)
meson.build(): don't use absolute path for include_dir()
No longer supported in Meson 0.39.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build5
1 files changed, 2 insertions, 3 deletions
diff --git a/meson.build b/meson.build
index bcb3a10..71c8ae2 100644
--- a/meson.build
+++ b/meson.build
@@ -76,9 +76,8 @@ if not cc.compiles(code, args: [ '-O0', '-Werror=unused-result' ])
add_global_arguments('-Wno-unused-result', language: 'c')
endif
-# current_build_dir() contains config.h
-include_dirs = include_directories('include', 'lib',
- meson.current_build_dir())
+# '.' will refer to current build directory, which contains config.h
+include_dirs = include_directories('include', 'lib', '.')
# Common dependencies
thread_dep = dependency('threads')