aboutsummaryrefslogtreecommitdiff
path: root/kernel/configure.ac
diff options
context:
space:
mode:
authorGravatar Miklos Szeredi <miklos@szeredi.hu>2006-10-11 05:44:55 +0000
committerGravatar Miklos Szeredi <miklos@szeredi.hu>2006-10-11 05:44:55 +0000
commit856e5cb2e11d39e5051d1bcf0bd872aadfb777ae (patch)
tree0209d745e81a6e938d6f8557cec60eb96ef0ff7b /kernel/configure.ac
parent53eec2a0d51ac5b126777fc61fa12bbc35a1a441 (diff)
Check for signature of super_operations->umount_begin()
Diffstat (limited to 'kernel/configure.ac')
-rw-r--r--kernel/configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/kernel/configure.ac b/kernel/configure.ac
index d0ebcc8..29e6ee3 100644
--- a/kernel/configure.ac
+++ b/kernel/configure.ac
@@ -149,6 +149,14 @@ if test "$ENABLE_FUSE_MODULE" = y; then
AC_MSG_RESULT([no])
fi
+ AC_MSG_CHECKING([if umount_begin is passed a vfsmount])
+ if egrep -q "\(\*umount_begin\) *\(struct vfsmount \*" $kernelsrc/include/linux/fs.h; then
+ AC_DEFINE(UMOUNT_BEGIN_VFSMOUNT, 1, [umount_begin is passed a vfsmount])
+ AC_MSG_RESULT([yes])
+ else
+ AC_MSG_RESULT([no])
+ fi
+
AC_MSG_CHECKING([whether lookup_instantiate_filp is defined])
if test -f $kernelsrc/include/linux/namei.h && egrep -q "lookup_instantiate_filp" $kernelsrc/include/linux/namei.h; then
AC_DEFINE(HAVE_LOOKUP_INSTANTIATE_FILP, 1, [lookup_instantiate_filp() is defined])