aboutsummaryrefslogtreecommitdiff
path: root/kernel/configure.ac
diff options
context:
space:
mode:
authorGravatar Miklos Szeredi <miklos@szeredi.hu>2007-02-03 11:28:17 +0000
committerGravatar Miklos Szeredi <miklos@szeredi.hu>2007-02-03 11:28:17 +0000
commit47910d7b8af40ffaccc8845d10d109871b5be604 (patch)
treec44982666a67e1d892bb5a3d69cf9643b65f44c8 /kernel/configure.ac
parent6e7d018049193efe9d092bb91c4416a332f28278 (diff)
merge to fuse_2_6_merge2
Diffstat (limited to 'kernel/configure.ac')
-rw-r--r--kernel/configure.ac14
1 files changed, 14 insertions, 0 deletions
diff --git a/kernel/configure.ac b/kernel/configure.ac
index dabd513..d54b711 100644
--- a/kernel/configure.ac
+++ b/kernel/configure.ac
@@ -179,6 +179,20 @@ if test "$ENABLE_FUSE_MODULE" = y; then
else
AC_MSG_RESULT([no])
fi
+ AC_MSG_CHECKING([if inode has i_mutex field ])
+ if egrep -qw "i_mutex" $kernelsrc/include/linux/fs.h; then
+ AC_DEFINE(HAVE_I_MUTEX, 1, [inode has i_mutex field])
+ AC_MSG_RESULT([yes])
+ else
+ AC_MSG_RESULT([no])
+ fi
+ AC_MSG_CHECKING([if kernel has mutex.h ])
+ if test -f $kernelsrc/include/linux/mutex.h; then
+ AC_DEFINE(HAVE_MUTEX_H, 1, [kernel has mutex.h])
+ AC_MSG_RESULT([yes])
+ else
+ AC_MSG_RESULT([no])
+ fi
isuml=no
KERNELMAKE_PARAMS=