aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorGravatar Miklos Szeredi <miklos@szeredi.hu>2010-11-08 16:00:16 +0100
committerGravatar Miklos Szeredi <mszeredi@suse.cz>2010-11-08 16:00:16 +0100
commiteba226948b44d5a303a10908d440e808eaf0bae6 (patch)
treed4159cf06f50b52cd3bfdfc6e6ec58d4969523e2 /configure.in
parent9b2ab7ebed39ab680e0d9a489e213cb8c4f49970 (diff)
update umount procedure
If umount(8) supports --fake and --no-canonicalize (util-linux-ng version 2.18 or later), and umount(2) supports the UMOUNT_NOFOLLOW flag (linux kernel version 2.6.35 or later) then, "fusermount -u" will call the umount(2) system call and use "umount --fake ..." to update /etc/mtab Added --disable-legacy-umount option to configure. This disables the runtime checking of umount(8) version. When built with this option then "fusermount -u" will fail if umount(8) doesn't support the --fake and --no-canonicalize options.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 3b64511..846868a 100644
--- a/configure.in
+++ b/configure.in
@@ -33,6 +33,8 @@ AC_ARG_ENABLE(example,
[ --enable-example Compile with examples ])
AC_ARG_ENABLE(mtab,
[ --disable-mtab Disable and ignore usage of /etc/mtab ])
+AC_ARG_ENABLE(legacy-umount,
+ [ --disable-legacy-umount If umount(8) is util-linux-ng >= 2.18 ])
AC_ARG_WITH(pkgconfigdir,
[ --with-pkgconfigdir=DIR pkgconfig file in DIR @<:@LIBDIR/pkgconfig@:>@],
@@ -54,6 +56,11 @@ fi
if test "$enable_mtab" = "no"; then
AC_DEFINE(IGNORE_MTAB, 1, [Don't update /etc/mtab])
fi
+
+if test "$enable_legacy_umount" != "no"; then
+ AC_DEFINE(LEGACY_UMOUNT, 1, [Enable legacy umount support])
+fi
+
AC_CHECK_FUNCS([fork setxattr fdatasync])
AC_CHECK_MEMBERS([struct stat.st_atim])
AC_CHECK_MEMBERS([struct stat.st_atimespec])