aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorGravatar Miklos Szeredi <miklos@szeredi.hu>2002-12-03 18:45:21 +0000
committerGravatar Miklos Szeredi <miklos@szeredi.hu>2002-12-03 18:45:21 +0000
commit5f0548192fc4df56e8b21c239f8f75479147e34a (patch)
tree816b8836046826e4db2213166a96cba0c59aca91 /configure.in
parent6bf8b68e0ee6596e8b5f0e53656a078bc5e579ba (diff)
fixes
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in17
1 files changed, 2 insertions, 15 deletions
diff --git a/configure.in b/configure.in
index 2238b60..dff58c6 100644
--- a/configure.in
+++ b/configure.in
@@ -21,6 +21,8 @@ AC_ARG_ENABLE(util,
AC_ARG_ENABLE(example,
[ --enable-example Compile with examples ])
+subdirs="include patch"
+
if test "$enable_kernel_module" != "no"; then
AC_MSG_CHECKING([kernel source directory])
kernelsrc=
@@ -40,16 +42,7 @@ if test "$enable_kernel_module" != "no"; then
fi
fi
AC_MSG_RESULT([$kernelsrc])
-fi
-
-oldcc=$CC
-oldcross_compiling=$cross_compiling
-if test "$cross_compiling" = yes; then
- CC=gcc
- cross_compiling=no
-fi
-if test "$enable_kernel_module" != "no"; then
AC_MSG_CHECKING([kernel source version])
kernsrcver=`sed -ne '/^VERSION = \(.*\)/{s//\1/;p;q;}' $kernelsrc/Makefile`
kernsrcver="$kernsrcver.`sed -ne '/^PATCHLEVEL = \(.*\)/{s//\1/;p;q;}' $kernelsrc/Makefile`"
@@ -63,13 +56,7 @@ if test "$enable_kernel_module" != "no"; then
*** configure the kernel before running this script])
fi
AC_MSG_RESULT([$kernsrcver])
-fi
-CC=$oldcc
-cross_compiling=$oldcross_compiling
-subdirs="include patch"
-
-if test "$enable_kernel_module" != "no"; then
KERNINCLUDE=$kernelsrc/include
AC_SUBST(KERNINCLUDE)
kmoduledir=/lib/modules/$kernsrcver