aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGravatar Eric Wong <normalperson@yhbt.net>2013-02-06 09:51:40 +0000
committerGravatar Miklos Szeredi <mszeredi@suse.cz>2013-02-06 16:30:47 +0100
commitfd7f25b62734ecdb63ed59001ef69a1a34edc4b4 (patch)
tree9a09af6e706b04932c805f090e406059ae516587 /configure.ac
parenteca08beaf5a7b4121da27c2a927a6ecbb08a74bf (diff)
libfuse: set close-on-exec flag on pipe file descriptors
The FUSE library may be used from any number of programs which may also fork() + execve(), so set the close-on-exec flag to avoid inadvertant leakage of pipe file descriptors. While we're at it, attempt to use pipe2() since this is within a (currently) Linux-only code path and pipe2() offers thread-safety.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 274ac70..7bf6553 100644
--- a/configure.ac
+++ b/configure.ac
@@ -52,7 +52,7 @@ if test "$enable_mtab" = "no"; then
AC_DEFINE(IGNORE_MTAB, 1, [Don't update /etc/mtab])
fi
-AC_CHECK_FUNCS([fork setxattr fdatasync splice vmsplice utimensat])
+AC_CHECK_FUNCS([fork setxattr fdatasync splice vmsplice utimensat pipe2])
AC_CHECK_FUNCS([posix_fallocate])
AC_CHECK_MEMBERS([struct stat.st_atim])
AC_CHECK_MEMBERS([struct stat.st_atimespec])