aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGravatar Nikolaus Rath <Nikolaus@rath.org>2016-12-23 18:47:01 -0800
committerGravatar Nikolaus Rath <Nikolaus@rath.org>2016-12-23 18:47:01 -0800
commitac25c153691faea65cbfc1b0781b8b0dab3f4b29 (patch)
tree5f004ce125166290895fe2c359de93fde15db71f /configure.ac
parent0fa25d046fcf9ea737a2165310dcad53814ffa2f (diff)
Set IGNORE_MTAB when running under NetBSD
Apparently, NetBSD does not have /etc/mtab. Setting IGNORE_MTAB in this case makes the code a little nicer. See also https://github.com/libfuse/libfuse/pull/123
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index d51e10a..ab3ec72 100644
--- a/configure.ac
+++ b/configure.ac
@@ -54,7 +54,8 @@ fi
if test "$enable_test" != "no"; then
subdirs2="$subdirs2 test";
fi
-if test "$enable_mtab" = "no"; then
+if test "$enable_mtab" = "no" -o \
+ "$arch" = "netbsd"; then
AC_DEFINE(IGNORE_MTAB, 1, [Don't update /etc/mtab])
fi