aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGravatar Eric Wong <normalperson@yhbt.net>2014-03-05 14:45:44 +0100
committerGravatar Miklos Szeredi <mszeredi@suse.cz>2014-03-05 14:45:44 +0100
commit6bf2e6f07c133f7b145a4726c5d962f14c650ca7 (patch)
tree7ab3a9941edad868c961404f0bbee23967990118 /configure.ac
parent0096c126aa4548df66c658afeb18a5a5356a2c57 (diff)
libfuse: implement readdirplus for high-level API
Reuse the old "readdir" callback, but add a flags argument, that has FUSE_READDIR_PLUS in case this is a "plus" version. Filesystems can safely ignore this flag, but if they want they can add optimizations based on it: i.e. only retrieve the full attributes in PLUS mode. The filler function is also given a flags argument and the filesystem can set FUSE_FILL_DIR_PLUS if all the attributes in "stat" are valid.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 04d7a6d..64b2af6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -54,7 +54,7 @@ if test "$enable_mtab" = "no"; then
fi
AC_CHECK_FUNCS([fork setxattr fdatasync splice vmsplice utimensat pipe2])
-AC_CHECK_FUNCS([posix_fallocate])
+AC_CHECK_FUNCS([posix_fallocate fstatat])
AC_CHECK_MEMBERS([struct stat.st_atim])
AC_CHECK_MEMBERS([struct stat.st_atimespec])