aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorGravatar Nikolaus Rath <Nikolaus@rath.org>2017-01-05 09:37:00 -0800
committerGravatar Nikolaus Rath <Nikolaus@rath.org>2017-01-12 15:19:04 -0800
commit9f96db71252fc66b72c433e2ca0d49e031c6a5fd (patch)
tree494132dae14dba3de18a9013f2299cfc37cceda5 /Makefile.am
parent3006686b536942f6f96675e3d12b793087e78e6a (diff)
Added experimental support for building with Meson+Ninja
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am21
1 files changed, 3 insertions, 18 deletions
diff --git a/Makefile.am b/Makefile.am
index 4e95a71..b2ba4b2 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -8,26 +8,11 @@ EXTRA_DIST = \
fuse3.pc.in \
README* \
test/*.py \
- test/pytest.ini
+ test/pytest.ini \
+ meson.build \
+ meson_options.txt
pkgconfigdir = @pkgconfigdir@
pkgconfig_DATA = fuse3.pc
$(pkgconfig_DATA): config.status
-
-.PHONY: setuid_fusermount
-setuid_fusermount:
- @echo "Attempting to use sudo to make util/fusermount3 setuid root"
- @echo "If this fails, set permissions manually and re-run make test"
- test $$(ls -n util/fusermount3 | awk 'NR==1 {print $$3}') -eq 0 || \
- sudo chown root util/fusermount3
- test -u util/fusermount3 || \
- sudo chmod u+s util/fusermount3
-
-# If we are not root, util/fusermount3 needs to be setuid root
-# for tests to work.
-
-test_deps = $(shell [ "$${UID}" -eq 0 ] || echo setuid_fusermount)
-.PHONY: test
-test: all $(test_deps)
- python3 -m pytest test/