aboutsummaryrefslogtreecommitdiffhomepage
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py6
1 files changed, 3 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index b87843f335..388e629ec2 100644
--- a/setup.py
+++ b/setup.py
@@ -276,11 +276,11 @@ PACKAGE_DIRECTORIES = {
}
INSTALL_REQUIRES = (
- "six>=1.5.2",
- "futures>=2.2.0 ; python_version<'3.2'",
- "enum34>=1.0.4 ; python_version<'3.4'"
+ 'six>=1.5.2',
)
+if not PY3:
+ INSTALL_REQUIRES += ('futures>=2.2.0', 'enum34>=1.0.4')
SETUP_REQUIRES = INSTALL_REQUIRES + (
'sphinx>=1.3',