aboutsummaryrefslogtreecommitdiffhomepage
path: root/setup.py
diff options
context:
space:
mode:
authorGravatar Mehrdad Afshari <mehrdada@users.noreply.github.com>2018-08-08 10:08:46 -0700
committerGravatar GitHub <noreply@github.com>2018-08-08 10:08:46 -0700
commitfd1771cfa096fe5f8adca3f096a42f901728a674 (patch)
tree2ddf70aef64653d2cc5c078f3a965890115d49bd /setup.py
parente916e79cb88b007559e079a8cac2250105a76954 (diff)
Revert "adding python version environmental markers in the new style"
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py6
1 files changed, 3 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index b87843f335..388e629ec2 100644
--- a/setup.py
+++ b/setup.py
@@ -276,11 +276,11 @@ PACKAGE_DIRECTORIES = {
}
INSTALL_REQUIRES = (
- "six>=1.5.2",
- "futures>=2.2.0 ; python_version<'3.2'",
- "enum34>=1.0.4 ; python_version<'3.4'"
+ 'six>=1.5.2',
)
+if not PY3:
+ INSTALL_REQUIRES += ('futures>=2.2.0', 'enum34>=1.0.4')
SETUP_REQUIRES = INSTALL_REQUIRES + (
'sphinx>=1.3',